Rango Broadband - Service outage in Grass Valley and Star City, – Incident details

All systems operational

Service outage in Grass Valley and Star City,

Resolved
Partial outage
Started 3 months agoLasted 23 minutes

Affected

Northern Nevada (Winnemucca/Golconda/Battle Mountain)

Partial outage from 4:56 PM to 5:20 PM

Winnemucca/Grass Valley/Golconda/95/Paradise)

Partial outage from 4:56 PM to 5:20 PM

ARPRT

Partial outage from 4:56 PM to 5:20 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently investigating this incident. Tech is on their way