Rango Broadband - Scheduled Maintenance – Incident details

All systems operational

Scheduled Maintenance

Resolved
Under maintenance
Started 6 months agoLasted about 4 hours

Affected

Northern Nevada (Winnemucca/Golconda/Battle Mountain)

Under maintenance from 3:35 PM to 7:29 PM

Winnemucca/Grass Valley/Golconda/95/Paradise)

Under maintenance from 3:35 PM to 7:29 PM

BIGG

Under maintenance from 3:35 PM to 7:29 PM

Updates
  • Resolved
    Resolved

    Work has been completed! If you are having issues with service we recommend power cycling your router if that doesn't help please call in!

  • Investigating
    Investigating

    We are going to starting our Scheduled Maintenance at the site.