Rango Broadband - Maintenance affecting Golconda – Incident details

All systems operational

Maintenance affecting Golconda

Resolved
Operational
Started 7 months agoLasted 5 days

Affected

Northern Nevada (Winnemucca/Golconda/Battle Mountain)

Partial outage from 3:55 PM to 9:34 PM

Winnemucca/Grass Valley/Golconda/95/Paradise)

Partial outage from 3:55 PM to 9:34 PM

GOLC

Partial outage from 3:55 PM to 9:34 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We are doing maintenance that is affecting service on this tower.