Rango Broadband - Power Outage – Incident details

All systems operational

Power Outage

Resolved
Operational
Started 10 months agoLasted about 8 hours

Affected

Western Nevada Network (Reno/Carson/Yerington/Silver Springs/ Fernley)

Major outage from 12:50 AM to 9:09 AM

Reno/Carson/Minden/Dayton

Major outage from 12:50 AM to 9:09 AM

SLID

Major outage from 12:50 AM to 9:09 AM

GEIG

Major outage from 12:50 AM to 9:09 AM

Fallen Leaf

Major outage from 12:50 AM to 9:09 AM

FLWP

Major outage from 12:50 AM to 9:09 AM

Updates
  • Resolved
    Resolved

    Power has been restored.

  • Update
    Update

    NV Energy has pushed this back to 9:45pm for restoration

  • Identified
    Identified

    Our Site has Lost power due to a NV Energy outage the ETA for the outage is 6PM due to weather conditions we are waiting out this outage since power should be restored by the time we would be able to reach the site. We apologize for any inconvenience this may cause.