Rango Broadband - Outage affecting south Battle Mountain. – Incident details

MRED experiencing major outage

Outage affecting south Battle Mountain.

Resolved
Major outage
Started about 2 months agoLasted about 20 hours

Affected

Northern Nevada (Winnemucca/Golconda/Battle Mountain)

Major outage from 7:47 PM to 3:18 PM

Battle Mountain

Major outage from 7:47 PM to 3:18 PM

MARY

Major outage from 7:47 PM to 3:18 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.