Rango Broadband - Outage affecting Dayton. – Incident details
Report an issue
Get updates
Email
SMS
Microsoft Teams
Webhook
Report an issue
Get updates
Dark mode
All systems operational
Outage affecting Dayton.
Resolved
Major outage
Started 7 months ago
Lasted 9 minutes
Updates
Resolved
May 23, 2025 at 1:30 AM
Resolved
May 23, 2025 at 1:30 AM
This incident has been resolved.
Investigating
May 23, 2025 at 1:21 AM
Investigating
May 23, 2025 at 1:21 AM
We are currently investigating this incident.